您的位置:首页 > 移动开发 > IOS开发

杭电1017 A Mathematical Curiosity

2016-02-03 23:35 417 查看
B - A Mathematical Curiosity
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input

1

10 1
20 3
30 4
0 0


Sample Output

Case 1: 2
Case 2: 4
Case 3: 5


这道题开始没读懂,意思就是先输入一个数表示组数,对于每一组都循环输入m,n,直到m,n都为0时这组结束,开始下一组,且每组之间有空行

#include<stdio.h>
int main()
{
int t,i,m,n,a,b;
scanf("%d",&t);
while(t--)
{
int s=1;
while(scanf("%d%d",&n,&m),n||m)   \\这个和( ,m,n)表示的并不一样
{
i=0;
for(b=2;b<n;b++)
for(a=1;a<b;a++)
if((a*a+b*b+m)%(a*b)==0) i++;
printf("Case %d: %d\n",s,i);
s++;
}
if(t)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: