您的位置:首页 > 其它

hdu 2509 Be the Winner 尼姆博奕

2016-02-02 21:24 330 查看
尼姆博奕


Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2821    Accepted Submission(s): 1547


Problem Description

Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.

For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 

the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

 

Input

You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

 

Output

If a winning strategies can be found, print a single line with "Yes", otherwise print "No".

 

Sample Input

2
2 2
1
3

 

Sample Output

No
Yes

 

Source

ECJTU 2008 Autumn Contest

 

/**==========================================
*   This is a solution for ACM/ICPC problem
*
*   @source:hdu 2509 Be the Winner
*   @type:
*   @author: wust_ysk
*   @blog:  http://blog.csdn.net/yskyskyer123 *   @email: 2530094312@qq.com
*===========================================*/
#include<cstdio>
using namespace std;
typedef long long ll;
int n,rich;
char type;

bool win()
{
if(type=='T'&&!rich)  return true;
if(type=='S'&&rich==1)  return true;
if(type=='S'&&rich>=2)  return true;//之前这里写成了rich>=2 Wa一发。
return false;
}
int main()
{
int x;
while(~scanf("%d",&n))
{
rich=0;
int sum=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&x);
if(x>1) rich++;
sum^=x;
}
type=sum?'S':'T';
puts( win()?"Yes":"No");

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: