您的位置:首页 > 其它

hdu 1907 John 尼姆博奕

2016-02-02 21:17 465 查看
尼姆博奕


John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 3849    Accepted Submission(s): 2182


Problem Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player
has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line
will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:

1 <= T <= 474,

1 <= N <= 47,

1 <= Ai <= 4747

 

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input

2
3
3 5 1
1
1

 

Sample Output

John
Brother

 

Source

Southeastern Europe 2007

 

/**==========================================
*   This is a solution for ACM/ICPC problem
*
*   @source:hdu 1907 John
*   @type:
*   @author: wust_ysk
*   @blog:  http://blog.csdn.net/yskyskyer123 *   @email: 2530094312@qq.com
*===========================================*/
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
const int INF =0x3f3f3f3f;
int n,rich;
char type;

bool win()
{
if(type=='T'&&!rich)  return true;
if(type=='S'&&rich==1)  return true;
if(type=='S'&&rich>=2)  return true;//之前这里写成了rich==2 Wa一发。
return false;
}
int main()
{
int T,x;scanf("%d",&T);
while(T--)
{
rich=0;
int sum=0;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&x);
if(x>1) rich++;
sum^=x;
}
type=sum?'S':'T';
puts( win()?"John":"Brother");

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: