您的位置:首页 > 大数据 > 人工智能

杭电1021Fibonacci Again

2016-02-02 17:49 465 查看
C Fibonacci Again
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5


Sample Output

no
no
yes
no
no
no


一开始直接把所有的f[i]算出来了,但是忽略了最后发f[i]会很大
所以使用同余定

#include<stdio.h>
int f[1000000];
int main()
{
int n;
f[0]=1;
f[1]=2;
for(int i=2;i<1000000;i++)
f[i]=(f[i-1]+f[i-2])%3;
while(~scanf("%d",&n))
{
if(f
==0)
printf("yes\n");
else
printf("no\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: