您的位置:首页 > 其它

Hdu 1075 What Are You Talking About

2016-02-02 10:38 423 查看


What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 18407    Accepted Submission(s): 6016


Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help
him?

 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains
two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single
line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new
word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single
string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

 

Output

In this problem, you have to output the translation of the history book.

 

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

 

Sample Output

hello, i'm from mars.
i like earth!

Hint
Huge input, scanf is recommended.

 

Author

Ignatius.L

思路:简单题目,这道题目是在搜索字典树的时候看到的题目,不过看了一下数据范围,感觉不需要用到字典树,于是试了一下暴力解决。分割一下字符串就行了,碰到是小写字母就先存一下,其他符号就先输出前面的内容,然后输出该符号,注意先判断下是不是END就行了。

AC代码如下:

#include <iostream>
#include <cstring>
#include <string>
#include <map>
#include <cstdio>
using namespace std;

map<string,string> mp;
char xx[3000+5];
char tmp[20];

int main(){

string tmp1,tmp2;
cin>>tmp1;

while(cin>>tmp1 && tmp1!="END"){
cin>>tmp2;
mp[tmp2]=tmp1;
}
gets(xx);gets(xx);
bool ok=false;
while(gets(xx)){
int len=strlen(xx);
int cnt=0;
for(int i=0;i<3;i++)
if(xx[i]>='A' && xx[i]<='Z'){
tmp[cnt++]=xx[i];
tmp[cnt]='\0';
}
if(strcmp(tmp,"END")==0){
ok=true;
break;
}

for(int i=0;i<len;i++){
if(xx[i]>='a' && xx[i]<='z'){
tmp[cnt++]=xx[i];
}
else {
tmp[cnt]='\0';
cnt=0;
if(!mp[tmp].empty()){
cout<<mp[tmp];
}
else cout<<tmp;
cout<<xx[i];
}
}
cout<<endl;
if(ok)break;
}

return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息