您的位置:首页 > 其它

poj 3211 结构体-分组一维dp

2016-02-01 00:12 183 查看
Washing Clothes

Time Limit: 1000MSMemory Limit: 131072K
Total Submissions: 9462Accepted: 3031
Description

Dearboy was so busy recently that now he has piles of clothes to wash. Luckily, he has a beautiful and hard-working girlfriend to help him. The clothes are in varieties of colors but each piece of them can be seen as of only one color. In order to prevent
the clothes from getting dyed in mixed colors, Dearboy and his girlfriend have to finish washing all clothes of one color before going on to those of another color.

From experience Dearboy knows how long each piece of clothes takes one person to wash. Each piece will be washed by either Dearboy or his girlfriend but not both of them. The couple can wash two pieces simultaneously. What is the shortest possible time they
need to finish the job?

Input

The input contains several test cases. Each test case begins with a line of two positive integers M and N (M < 10, N < 100), which are the numbers of colors and of clothes. The next line contains M strings which
are not longer than 10 characters and do not contain spaces, which the names of the colors. Then follow N lines describing the clothes. Each of these lines contains the time to wash some piece of the clothes (less than 1,000) and its color. Two zeroes
follow the last test case.

Output

For each test case output on a separate line the time the couple needs for washing.

Sample Input
3 4
red blue yellow
2 red
3 blue
4 blue
6 red
0 0

Sample Output
10


题意: 俩人洗衣服。。你一件我一件

必须俩人把同一个色的洗完才能洗下一个颜色的。问最小时间是多少

因为有n个颜色的,所以整个背包问题循环n次,每次找寻 最大限度的填满 T/2的方案。T为这个颜色的衣服总时间

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int m,n;
int dp[1000005];

struct COLOR{
char color[12];
int time[105];
int num;
int sum;
}one_of_color[12];

void inta()
{
for(int i=0;i<m;i++){
scanf("%s",one_of_color[i].color);
one_of_color[i].sum=0;
one_of_color[i].num=0;
}

int t;
char temp[15];
for(int i=0;i<n;i++){
scanf("%d%s",&t,temp);

for(int j=0;j<m;j++){
if(!strcmp(temp,one_of_color[j].color)){

one_of_color[j].time[one_of_color[j].num++]=t;
one_of_color[j].sum+=t;
break;
}
}
}
}

void deal()
{
int ans=0;
for(int i=0;i<m;i++){

memset(dp,0,sizeof(dp));
int temp=one_of_color[i].sum/2;

for(int j=0;j<one_of_color[i].num;j++){

for(int k=temp;k>=one_of_color[i].time[j];k--){
dp[k]=max(dp[k],dp[k-one_of_color[i].time[j]]+one_of_color[i].time[j]);
}
}
ans=ans+one_of_color[i].sum-dp[temp];
}

printf("%d\n",ans);
}

int main()
{
while(scanf("%d%d",&m,&n),m&&n){

inta();
deal();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: