您的位置:首页 > 其它

ZOJ 3203 Light Bulb (三分)

2016-01-31 21:01 260 查看
Light Bulb
Time Limit: 1 Second      Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day,
he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is
the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >=
10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

题意:一个灯的高度H,一个人的高度h,灯和墙的距离水平距离D,求形成影子的最长长度

思路:根据图发现影子分为两部分,地上一部分,墙上一部分,然后通过换算可知道总长度L=(h-x)/(H-x)*D+x,
其中x为墙上影子的高度,所以知道x范围为(0,h),可知此函数为凸型函数,所以说用三分法查找

ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
#define eps 1e-10
using namespace std;
int gcd(int a,int b){return b?gcd(b,a%b):a;}
LL powmod(LL a,LL b,LL MOD){LL ans=1;while(b){if(b%2)ans=ans*a%MOD;a=a*a%MOD;b/=2;}return ans;}
//head
double H,h,D;
double fun(double x)
{
return (h-x)*D/(H-x)+x;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%lf%lf%lf",&H,&h,&D);
double low=0.0,high=h;
double mid,mmid;
while(high-low>eps)
{
mid=(low+high)/2.0;
mmid=(mid+high)/2.0;
if(fun(mid)>fun(mmid))
high=mmid;
else
low=mid;
}
printf("%.3lf\n",fun(high));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: