您的位置:首页 > 其它

ZOJ-2850-Beautiful Meadow【暴力】【4th浙江省赛】

2016-01-31 19:53 489 查看

ZOJ-2850-Beautiful Meadow

Time Limit: 2 Seconds      Memory Limit: 65536 KB


Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

Not all squares are covered with grass.

No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom’s meadow beautiful now?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers N, M (1 <= N, M <= 10) separated by a space. There follows the description of Tom’s Meadow. There’re N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output

One line for each test case.

Output “Yes” (without quotations) if the meadow is beautiful, otherwise “No”(without quotations).

Sample Input

2 2

1 0

0 1

2 2

1 1

0 0

2 3

1 1 1

1 1 1

0 0

Sample Output

Yes

No

No

题目链接:ZOJ-2850

题目大意:给出一n*m只含有0 or 1的图。是否满足两个条件:1.不含有相邻的0; 2.存在0

题目思路:直接暴力

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
int a[20][20] = {0};
int n,m;
bool isbeauty()
{
int flag = 0;
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m - 1; j++)
{
if (a[i][j] == 0) flag = 1;
if (a[i][j] == 0 && a[i][j + 1] == 0) return 0;
}
}
for (int j = 0; j < m; j++)
{
for (int i = 0; i < n - 1; i++)
{
if (a[i][j] == 0) flag = 1;
if (a[i][j] == 0 && a[i + 1][j] == 0) return 0;
}
}
if (flag) return 1;
else return 0;
}
int main(){
while(cin >> n >> m)
{
if (n == 0 && m == 0) break;
memset(a,0,sizeof(a));
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
cin >> a[i][j];
}
}
int ans = isbeauty();
if (ans) cout << "Yes\n";
else cout << "No\n";
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  zoj 2850