您的位置:首页 > 其它

POJ 2505:A multiplication game

2016-01-31 14:39 337 查看
A multiplication game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5624 Accepted: 2813
Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer
1 < n < 4294967295 and the winner is who first reaches p >= n.
Input

Each line of input contains one integer number n.
Output

For each line of input output one line either 

Stan wins. 

or 

Ollie wins. 

assuming that both of them play perfectly.
Sample Input
162
17
34012226

Sample Output
Stan wins.
Ollie wins.
Stan wins.

Source
Waterloo local 2001.09.22


你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include <iostream>
using namespace std;
int main()
{
double n;
while(cin>>n)
{
while(n > 18)n/=18;
if(n <= 9)cout << "Stan wins." << endl;
else cout << "Ollie wins." << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: