您的位置:首页 > 其它

poj 2960 S-Nim(SG函数)

2016-01-30 20:08 495 查看
S-Nim

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 3694Accepted: 1936
Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

The players take turns chosing a heap and removing a positive number of beads from it.

The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they
recently learned an easy way to always be able to find the best move:

Xor
the number of beads in the heaps in the current position (i.e. if we
have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

If the xor-sum is 0, too bad, you will lose.

Otherwise, move such that the xor-sum becomes 0. This is always possible.

It is quite easy to convince oneself that this works. Consider these facts:

The player that takes the last bead wins.

After the winning player's last move the xor-sum will be 0.

The xor-sum will change after every move.

Which
means that if you make sure that the xor-sum always is 0 when you have
made your move, your opponent will never be able to win, and, thus, you
will win.

Understandibly it is no fun to play a game when both players know
how to play perfectly (ignorance is bliss). Fourtunately, Arthur and
Caroll soon came up with a similar game, S-Nim, that seemed to solve
this problem. Each player is now only allowed to remove a number of
beads in some predefined set S, e.g. if we have S = {2, 5} each player
is only allowed to remove 2 or 5 beads. Now it is not always possible to
make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of
S-Nim is a losing or a winning position. A position is a winning
position if there is at least one move to a losing position. A position
is a losing position if there are no moves to a losing position. This
means, as expected, that a position with no legal moves is a losing
position.
Input

Input consists of a number of test cases.

For each test case: The first line contains a number k (0 < k ≤
100) describing the size of S, followed by k numbers si (0 < si ≤
10000) describing S. The second line contains a number m (0 < m ≤
100) describing the number of positions to evaluate. The next m lines
each contain a number l (0 < l ≤ 100) describing the number of heaps
and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the
heaps.

The last test case is followed by a 0 on a line of its own.
Output

For
each position: If the described position is a winning position print a
'W'.If the described position is a losing position print an 'L'.

Print a newline after each test case.
Sample Input

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

Sample Output

LWW
WWL

Source

Svenskt Mästerskap i Programmering/Norgesmesterskapet 2004

【思路】

SG函数。

裸ti ,注意下sg和vis的大小就好了 :)

【代码】

#include<cstdio>
#include<cstring>
#define FOR(a,b,c) for(int a=(b);a<(c);a++)
using namespace std;

int n,m,a[101],sg[10001];

int dfs(int x) {
if(sg[x]!=-1) return sg[x];
if(!x) return sg[x]=0;
int vis[10001];                    //size of [si]
memset(vis,0,sizeof(vis));
FOR(i,0,n)
if(x>=a[i]) vis[dfs(x-a[i])]=1;
for(int i=0;;i++)
if(!vis[i]) return sg[x]=i;
}

int main() {
while(scanf("%d",&n)==1 && n) {
FOR(i,0,n) scanf("%d",&a[i]);
scanf("%d",&m);
memset(sg,-1,sizeof(sg));
FOR(i,0,m) {
int x,v,ans=0;
scanf("%d",&x);
FOR(j,0,x)
scanf("%d",&v) , ans^=dfs(v);
if(ans) printf("W");
else printf("L");
}
putchar('\n');
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: