您的位置:首页 > 其它

HDU 1016 Prime Ring Problem(dfs)

2016-01-29 20:41 423 查看
Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 37703 Accepted Submission(s): 16659

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6

8

Sample Output

Case 1:

1 4 3 2 5 6

1 6 5 2 3 4

Case 2:

1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

Source

Asia 1996, Shanghai (Mainland China)

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
bool vis[20];
int a[20];
int n;
bool prime(int m)
{
if(m==1) return false;
if(m==2) return true;
for(int i=2;i*i<=m;i++)
if(m%i==0) return false;
return true;
}
void dfs(int m)
{
if(m==n&&prime(a[m-1]+a[0])){
for(int i=0;i<m;i++){
if(i) cout<<" ";
cout<<a[i];
}
cout<<endl;
}
else{
for(int i=2;i<=n;i++){
if(!vis[i]){
if(prime(i+a[m-1])){ //是否和相邻的加起来是素数
vis[i]=1;//标记了
a[m++]=i;//放进数组
dfs(m); //递归调用
vis[i]=0; //退去标记
m--;
}
}
}
}
}
int main()
{
int j=0;
while(cin>>n){
cout<<"Case "<<++j<<":"<<endl;
memset(vis,0,sizeof(vis));
a[0]=1;
dfs(1);
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: