您的位置:首页 > 运维架构

poj2115C Looooops【扩展欧几里得】

2016-01-28 14:52 281 查看
Language:
Default

C Looooops

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21152 Accepted: 5740
Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming
that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k. 

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C
< 2k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input
3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output
0
2
32766
FOREVER


//题意求(x*c)%(1<<k)=b-a的x最小解
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<list>
#include<queue>
using namespace std;
void exgcd(long long a,long long b,long long &x,long long &y,long long &cnt){
if(b){
exgcd(b,a%b,y,x,cnt);
y-=(a/b)*x;
}
else{
x=1;y=0;
cnt=a;
}
}
int main()
{
int i,j;
long long a,b,c,k;
while(scanf("%lld%lld%lld%lld",&a,&b,&c,&k),a+b+c+k){
long long num=1;num<<=k;
long long x,y,cnt;
exgcd(c,num,x,y,cnt);
if((b-a)%cnt){
printf("FOREVER\n");
}
else {
x=x*(b-a)/cnt;
cnt=num/cnt;
x=(x%cnt+cnt)%cnt;
printf("%lld\n",x);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息