您的位置:首页 > 其它

hdu 1708 Fibonacci String

2016-01-28 13:49 351 查看

Fibonacci String

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5012 Accepted Submission(s):
1693


[align=left]Problem Description[/align]
After little Jim learned Fibonacci Number in the class
, he was very interest in it.
Now he is thinking about a new thing --
Fibonacci String .

He defines : str
= str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and
str[1], he will calculate the str[2],str[3],str[4] , str[5]....

For
example :
If str[0] = "ab"; str[1] = "bc";
he will get the result ,
str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;

As the string
is too long ,Jim can't write down all the strings in paper. So he just want to
know how many times each letter appears in Kth Fibonacci String . Can you help
him ?

[align=left]Input[/align]
The first line contains a integer N which indicates the
number of test cases.
Then N cases follow.
In each case,there are two
strings str[0], str[1] and a integer K (0 <= K < 50) which are separated
by a blank.
The string in the input will only contains less than 30 low-case
letters.

[align=left]Output[/align]
For each case,you should count how many times each
letter appears in the Kth Fibonacci String and print out them in the format
"X:N".
If you still have some questions, look the sample output
carefully.
Please output a blank line after each test case.

To make
the problem easier, you can assume the result will in the range of int.

[align=left]Sample Input[/align]

1
ab bc 3

[align=left]Sample Output[/align]

a:1

b:3

c:2

d:0
e:0
f:0

g:0
h:0
i:0
j:0

k:0
l:0

m:0

n:0

o:0

p:0

q:0

r:0

s:0

t:0

u:0

v:0

w:0

x:0

y:0

z:0

[align=left]Author[/align]
linle

[align=left]Source[/align]
HDU
2007-Spring Programming Contest

[align=left]Recommend[/align]
lcy | We have carefully selected several similar
problems for you: 1709 1710 1707 1701 1714

很简单的模拟题,注意给的第一个数是s0

题意:给两个字符串s0和s1,sn是sn-1和sn-2拼接而成的。问sn中每个字母出现的次数

附上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
int f[50][30];
char s1[35],s2[35];
int i,j,T,n,m;
scanf("%d",&T);
while(T--)
{
scanf("%s %s %d",s1,s2,&n);
memset(f,0,sizeof(f));
for(i=0; s1[i]!='\0'; i++)
f[0][s1[i]-'a']++;            //字母转化为数字保存
for(i=0; s2[i]!='\0'; i++)
f[1][s2[i]-'a']++;
for(i=2; i<=n; i++)
{
for(j=0; j<26; j++)
f[i][j]=f[i-1][j]+f[i-2][j]; //每一次都是前面两个相加
}
for(i=0; i<26; i++)
printf("%c:%d\n",i+'a',f
[i]);  //输出26个字母的个数
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: