您的位置:首页 > 编程语言 > PHP开发

HDOJ 1096 A+B for Input-Output Practice (VIII)

2016-01-28 08:46 531 查看

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 130346 Accepted Submission(s): 39693



Problem Description

Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3


Sample Output

10

15

6//
//  main.cpp
//  A+B for Input-Output Practice (VIII)
//
//  Created by 张嘉韬 on 16/1/28.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
using namespace std;
int main(int argc, const char * argv[]) {
int nu,sum,temp;
cin>>nu;
for(int t=1;t<=nu;t++)
{
int n;
cin>>n;
sum=0;
for(int i=1;i<=n;i++)
{
cin>>temp;
sum+=temp;
}
cout<<sum<<endl;
if(t!=nu) cout<<endl;
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: