您的位置:首页 > 运维架构

POJ 1505 Copying Books

2016-01-27 21:31 381 查看
Copying Books

Time Limit: 3000MSMemory Limit: 10000K
Total Submissions: 7620Accepted: 2405
Description

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers
lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books.
Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber
only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < bk-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1+1 and
bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are
integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000.
Output

For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character ('/') to separate the parts. There
must be exactly one space character between any two successive numbers and between the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.
Sample Input
2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output
100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

Source

Central Europe 1998

dp[i][j]表示第i个往后的所有数分成j部分的每部分和的最小值。

注意最后答案要使得斜杠尽量往前摆,需要进行一个调整,从前往后看每个斜杠,如果该斜杠往前移动一位,对后面的数进行划分的结果小于整体最优解,则斜杠可以向前移动一位。

代码:

#include<cstdio>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
#define N 1010
#define ll long long

ll val
, sum
;
ll dp

;
int fa

, pos
;

int main()
{
//freopen("C:\\Users\\zfh\\Desktop\\in.txt", "r", stdin);
//freopen("C:\\Users\\zfh\\Desktop\\out.txt", "w", stdout);
int t; scanf("%d", &t);
while(t--)
{
int n, m;
scanf("%d%d", &n, &m);
sum[0] = 0;
for(int i = 1; i <= n; i++)
{
scanf("%I64d", &val[i]);
sum[i] = sum[i-1]+val[i];
}

for(int i = 1; i <= n; i++)
dp[i][1] = sum
-sum[i-1];
for(int i = 2; i <= m; i++)
{
for(int j = 1; j <= n && n-j+1 >= i; j++)
{
dp[j][i] = max(dp[j+1][i-1], val[j]);
fa[j][i] = j;
for(int k = j+1; k <= n && n-k >= i-1; k++)
{
if(dp[j][i] > max(sum[k]-sum[j-1], dp[k+1][i-1]))
{
dp[j][i] = max(sum[k]-sum[j-1], dp[k+1][i-1]);
fa[j][i] = k;
}

}
}
}
//printf("dp: %I64d\n", dp[1][m]);
int p = 1, maxv = dp[1][m];
for(int i = 1; i <= m-1; i++)
{
pos[i] = fa[p][m-i+1];
p = fa[p][m-i+1]+1;
}

pos[m] = n;
for(int i = 1; i <= m-1; i++)
{
while(pos[i]-1 > pos[i-1] && dp[pos[i]][m-i] <= maxv)
pos[i]--;
}

p = 1;
for(int i = 1; i <= n; i++)
{
if(i != 1) printf(" ");
printf("%I64d", val[i]);
if(i == pos[p] && p != m)
{
printf(" /");
p++;
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: