您的位置:首页 > 其它

HDOJ 1019 Least Common Multiple (求n个数的LCM)

2016-01-27 17:55 330 查看

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 42352    Accepted Submission(s): 15931


[align=left]Problem Description[/align]
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

[align=left]Input[/align]
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where
m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

[align=left]Output[/align]
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

[align=left]Sample Input[/align]

2
3 5 7 15
6 4 10296 936 1287 792 1

 

[align=left]Sample Output[/align]

105
10296

 

题意:求n个数最小公倍数

思路:题目不难,但是有几个小细节:

1.输入的数可能为0

2.更新ans(最小公倍数)的时候可能会爆int,所以说先除后乘,也可以用longlong

ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
using namespace std;
int gcd(int a,int b)
{
return b?gcd(b,a%b):a;
}
int main()
{
int t,n,a,i;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
if(n==0)
{
printf("0\n");
continue;
}
int ans;
scanf("%d",&a);
ans=a;
int bz=0;
for(i=1;i<n;i++)
{
scanf("%d",&a);
if(bz)
continue;
if(a==0)
ans=0,bz=1;
int k=gcd(a,ans);
if(k==0)
ans=0;
else
ans=a/k*ans;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: