您的位置:首页 > 其它

HDOJ 2054 A == B ?(精确大数相等)

2016-01-27 16:47 267 查看
Problem Description

Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print “YES”, or print “NO”.

Sample Input

1 2

2 2

3 3

4 3

Sample Output

NO

YES

YES

NO

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
BigDecimal A = sc.nextBigDecimal();
BigDecimal B = sc.nextBigDecimal();

if(A.compareTo(B)==0){
System.out.println("YES");
}else{
System.out.println("NO");
}
}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: