您的位置:首页 > 其它

hdu 2612 两路广搜

2016-01-27 16:15 417 查看


Find a way

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8189 Accepted Submission(s): 2645



Problem Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.

Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.

Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input

The input contains multiple test cases.

Each test case include, first two integers n, m. (2<=n,m<=200).

Next n lines, each line included m character.

‘Y’ express yifenfei initial position.

‘M’ express Merceki initial position.

‘#’ forbid road;

‘.’ Road.

‘@’ KCF

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#


Sample Output

66
88
66


遇到的问题和思路:

这道题没有看别人的代码,也没有看题解,过了好开心啊,哈哈。

先说说看到这道题的思路吧。首先看到这道题目其实感觉不会,然后刚开始的想法是把每一个@列举出来,从@到M或者Y的,但是发现这样子的逆向思维不行,因为n*m最大是40000,如果40000都是@,那么肯定会超时。然后就回到了从Y和M出发,map来储存地图,mapy来储存Y到@的最小步数,mapm来储存M到@的最小步数。起初是打算就写一个BFS的,然后是打算这么写bfs(int x , int y, int a[][]);结果发现这个样子貌似系统不可以,然后我也不知道二位数组到底怎么用到同一个函数里面,于是就乖乖的粘贴复制。然后再最后的时候一直都是WA(那个时候测试了discuss里面的好多组数据,还有测试了系统本来给的数据,都是对的),结果检查来检查去,发现,原来是两个BFS的函数里面的循环的n,m弄错了,然而测试的数据都是n
= m,难怪一直WA

给出AC代码:



#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define inf 20000000

using namespace std;

int n, m;
typedef pair<int int=""> P;
char map[205][205];
int mapy[205][205];
int mapm[205][205];
int dx[4] = {0, 1, -1, 0};
int dy[4] = {-1, 0, 0, 1};
int res, nx, ny, ans;

void bfs1(int x, int y){
queue <p> que;
que.push(P(x, y));
mapy[x][y] = 0;
ans = 0;
while(!que.empty()){
P p = que.front();
que.pop();
/*if(ans == res)break;
if(map[p.first][p.second] == '@') ans++;*/
for(int i = 0; i < 4; i++){
nx = p.first + dx[i]; ny = p.second + dy[i];
if(nx >= 0 && nx < n && ny >= 0 && ny < m && mapy[nx][ny] == inf && map[nx][ny] != '#'){//这里的ny一直写成<n了,TAT
que.push(P(nx, ny));
mapy[nx][ny] = mapy[p.first][p.second] + 1;
}
}
}

}

void bfs2(int x, int y){
queue </p><p> que;
que.push(P(x, y));
mapm[x][y] = 0;
ans = 0;
while(!que.empty()){
P p = que.front();
que.pop();
/*if(ans == res)break;
if(map[p.first][p.second] == '@') ans++;*/
for(int i = 0; i < 4; i++){
nx = p.first + dx[i]; ny = p.second + dy[i];
if(nx >= 0 && nx < n && ny >= 0 && ny < m && mapm[nx][ny] == inf && map[nx][ny] != '#'){//这里的ny一直写成<n了,TAT
que.push(P(nx, ny));
mapm[nx][ny] = mapm[p.first][p.second] + 1;
}
}
}
}

void solve(){
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
if(map[i][j] == 'Y'){
bfs1(i, j);
}
if(map[i][j] == 'M'){
bfs2(i, j);
}
}
}
int sum = inf;
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
if(map[i][j] == '@'){
//printf("%d %d\n", mapy[i][j], mapm[i][j]);
sum = min((mapy[i][j] + mapm[i][j]) * 11, sum);
}
}
}
printf("%d\n",sum);
}

int main(){
while(scanf("%d%d",&n,&m)!=EOF){
res = 0;
getchar();
memset(map, '\0', sizeof(map));
for (int i = 0; i < 205; i++){
fill (mapy[i], mapy[i] + 205, inf);
fill (mapm[i], mapm[i] + 205, inf);
}

for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
scanf("%c",&map[i][j]);
}
getchar();
}
solve();
}
return 0;
}
</p></int></queue></cmath></cstring></cstdio>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: