您的位置:首页 > 其它

HDOJ 2051 Bitset

2016-01-27 15:37 316 查看
Problem Description

Give you a number on base ten,you should output it on base two.(0 < n < 1000)

Input

For each case there is a postive number n on base ten, end of file.

Output

For each case output a number on base two.

Sample Input

1

2

3

Sample Output

1

10

11

就是将一个十进制的数按二进制输出。

JAVA中直接调用Integer.toBinaryString(int i);

以二进制(基数 2)无符号整数形式返回一个整数参数的字符串表示形式。

import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
int n = sc.nextInt();

System.out.println(Integer.toBinaryString(n));

}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: