您的位置:首页 > Web前端

杭电1015——Safecracker(dfs、递归枚举排列)

2016-01-27 13:38 295 查看
Problem Description

=== Op tech briefing, 2002/11/02 06:42 CST ===

“The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein’s secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, …, Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary.”

v - w^2 + x^3 - y^4 + z^5 = target

“For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn’t exist then.”

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

“Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution’ if there is no correct combination. Use the exact format shown below.”

Sample Input

1 ABCDEFGHIJKL

11700519 ZAYEXIWOVU

3072997 SOUGHT

1234567 THEQUICKFROG

0 END

Sample Output

LKEBA

YOXUZ

GHOST

no solution

算法:

主要就是递归枚举排列,没什么好讲的,直接上代码。写递归时,注意递归出口,千万不能写错了。刚开始时,写成只有找到解,才return。其实,只要cur==5,不管是否是解,都要return .

# include<iostream>
# include<cstdio>
# include<string>
# include<algorithm>
# include<cmath>
using namespace std;

int flag;
int target,len;
char Letter[15],result[6];
void dfs(int cur);
int visited[15];

int main()
{
while(scanf("%d%s",&target,Letter)==2)
{
if(target==0&&strcmp(Letter,"END")==0)
break;
flag=0;
memset(visited,0,sizeof(int)*15);
len=strlen(Letter);
sort(Letter,Letter+len);
dfs(0);
if(!flag)
printf("no solution\n");
}
return 0;
}

void dfs(int cur)
{
int i;
if(cur==5)
{
int v,w,x,y,z;
v=result[0]-64;
w=result[1]-64;
x=result[2]-64;
y=result[3]-64;
z=result[4]-64;
int sum=v-w*w+x*x*x-y*y*y*y+z*z*z*z*z;
if(sum==target)
{
for(i=0;i<5;i++)
printf("%c",result[i]);
printf("\n");
flag=1;
}
return;
}
for(i=strlen(Letter)-1;i>=0;i--)
{
if(!visited[i])
{
result[cur]=Letter[i];
visited[i]=1;
dfs(cur+1);
if(flag)
break;
visited[i]=0;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: