您的位置:首页 > 其它

poj 2769 Reduced ID Numbers(memset使用技巧)

2016-01-27 12:54 429 查看
DescriptionT. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identificationwithin her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.InputOn the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each containone SIN. The SINs within a group are distinct, though not necessarily sorted.OutputFor each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.Sample Input
2
1
124866
3
124866
111111
987651
Sample Output
1
8
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int t[310];
bool vis[1000010];

int main()
{
int n;
scanf("%d",&n);
while(n--)
{
int m,i,j;
scanf("%d",&m);
for(i=1;i<=m;i++)
cin>>t[i];
for(i=m;;i++)
{
memset(vis,false,i*sizeof(vis[0])); //时间172ms
for(j=1;j<=m;j++)                   //memset(vis,false,sizeof(vis));    tle
if(vis[t[j]%i]) break;
else vis[t[j]%i]=true;
if(j>m) break;
}
printf("%d\n",i);
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: