您的位置:首页 > 其它

hdu 2138(米勒—拉宾素数测试)

2016-01-27 12:18 239 查看

     How many prime numbers

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


[align=left]Problem Description[/align]
  Give you a lot of positive integers, just to find out how many prime numbers there are.
 

[align=left]Input[/align]
  There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 

[align=left]Output[/align]
  For each case, print the number of prime numbers you have found out.
 

[align=left]Sample Input[/align]

3
2 3 4

 

[align=left]Sample Output[/align]

2

 

解题思路:这道题目如果靠筛选法那肯定会超时。米勒—拉宾素数测试可以进行大素数判断。。。
米勒—拉宾素数测试主要依靠两个基本定理:
1)费马小定理:当gcd(a,p)=1且p为素数时,有a^p-1 mod p = 1
2)快速幂取模算法(RSA公钥加密算法)
其实这个算法模板我也没有很明白,先凑合着看吧。。。

AC:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

__int64 qpow(int a,int b,int r)
{
__int64 ans = 1,buff = a;
while(b)
{
if(b & 1)
ans = (ans*buff) % r;
buff = (buff*buff) % r;
b >>= 1;
}
return ans;
}

bool Miller_Rabbin(int n,int a)
{
int r = 0,s = n-1,j;
if(!(n % a)) return false;
while(!(s & 1))
{
s >>= 1;
r++;
}
__int64 k = qpow(a,s,n);
if(k == 1)
return true;
for(j = 0; j < r; j++, k = k * k % n)
if(k == n-1)
return true;
return false;
}

bool isPrime(int n)
{
int tab[4] = {2,3,5,7};
for(int i = 0; i < 4; i++)
{
if(n == tab[i])
return true;
if(!Miller_Rabbin(n,tab[i]))
return false;
}
return true;
}

int main()
{
int n;
while(cin>>n)
{
int a,ans = 0;
while(n--)
{
cin>>a;
if(isPrime(a))
ans++;
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学