您的位置:首页 > 其它

2015省赛 D Beauty of Array【递推】【数学】

2016-01-27 11:48 281 查看

Beauty of Array

Time Limit: 2 Seconds      Memory Limit: 65536 KB


Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3

5

1 2 3 4 5

3

2 3 3

4

2 3 3 2

Sample Output

105

21

38

Author:

LIN, Xi

Source:

The 12th Zhejiang Provincial Collegiate Programming Contest

思路

递推,设sum[i]为以i为终点的区间的独立数字的和,则
sum[i]=sum[i-1]+(i-pre[x])*x
,其中pre[x]表示上一次x出现的位置。

就是说,每加进来一个数字,考虑以这个数字为终点的所有的区间,在x出现前最后一次出现x的位置为pre[x],则x对起点在pre[x]之前(包括)的区间都是重复的,所以要减掉。

这里还有一个小坑就是可能会溢出。

AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;

int pre[1000000+100];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(pre,0,sizeof pre);
int n;
scanf("%d",&n);
ll ans=0,sum=0;
for(int i=1; i<=n ; ++i)
{
ll x;
scanf("%lld",&x);
sum+=(i-pre[x])*x;
ans+=sum;
pre[x]=i;
}
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学 算法