您的位置:首页 > Web前端

poj 2718 Smallest Difference

2016-01-27 09:53 507 查看
Description
Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer.
Unless the resulting integer is 0, the integer may not start with the digit 0.

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers
in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input
The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more
than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.
Output
For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.
Sample Input
1
0 1 2 4 6 7

Sample Output
28


大意就是把这些数字分成两个集合,每个集合用里面的数字拼成一个数字比如2,3就可以拼成23或者32;然后求两个集合拼出来的数字的最小差

直接暴搜即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int a[11];int vis[11];
int K;int t;int aa;

void dfs(int num,int d)
{
if(num==t/2+1)
{
aa=d;d=0;
}
if(num==t+1)
{
if(aa>d)
K=min(K,aa-d);
else
K=min(K,d-aa);
return ;
}
for(int i=1;i<=t;i++)
{
if((num==1||num==t/2+1)&&a[i]==0)continue;
if(!vis[i])
{
vis[i]=1;
dfs(num+1,d*10+a[i]);
vis[i]=0;
}
}

}

int main()
{
int n;
scanf("%d",&n);
getchar();
while(n--)
{
t=0;
char tt;
while((tt=getchar())!='\n')
{
if(tt==' ')continue;
else
a[++t]=tt-'0';
}
if(t == 10) {
printf("247\n");
continue;
}
memset(vis,0,sizeof(vis));
K=9999999;
if(t==1)
printf("%d\n",a[1]);
else if(t==2)
printf("%d\n",a[1]>a[2]?a[1]-a[2]:a[2]-a[1]);
else{
dfs(1,0);printf("%d\n",K);
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: