您的位置:首页 > Web前端

nyoj 1242 Interference Signal (河南省第八届acm程序设计大赛)

2016-01-26 23:25 393 查看
题目1242
题目信息
运行结果
本题排行
讨论区

Interference Signal

时间限制:2000 ms | 内存限制:65535 KB

难度:1

描述
Dr.Kong’s laboratory monitor some interference signals. The interference signals can be digitized into a series of positive integer. May be, there are
N integers a1,a2,…,an.

Dr.Kong wants to know the
average strength of a contiguous interference signal block.
the block must contain at least M integers.

Please help Dr.Kong to calculate the
maximum average strength, given the constraint.
输入The input contains K test cases. Each test case specifies:

* Line 1: Two space-separated integers, N and M.

* Lines2~line N+1: ai (i=1,2,…,N)

1 ≤ K≤ 8, 5 ≤ N≤ 2000, 1 ≤ M ≤ N, 0 ≤ ai ≤9999

输出For each test case generate a single line containing a single integer that is 1000 times the maximal average value. Do not perform rounding.样例输入
2 10 66 42103859415 210385 9

样例输出
65007333

来源第八届河南省程序设计大赛上传者
hnu_acm

两个注意点 一个是at least 一个是 Do not perform rounding.

#include <stdio.h>
#include <string.h>
int main()
{
	int ncase,a[2005];
	scanf("%d",&ncase);
	while(ncase--)
	{
		int n,m;
		double sum,max=-0x3fffffff;
		memset(a,0,sizeof(a));
		scanf("%d %d",&n,&m);
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		for(int i=0;i+m<=n;i++)
		{
			for(int k=m;k<=n&&i+k<=n;k++)
			{
				sum=0;
				for(int j=0;j<k;j++)
				sum+=a[i+j];
				if(sum/k>max)
				max=sum/k;
			}
		}
		printf("%d\n",(int)(max*1000));
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: