您的位置:首页 > 其它

HDU 3835 R(N)(枚举)

2016-01-26 15:44 375 查看
题目链接

Problem Description

We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example,
10=(-3)^2+1^2.
We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).

[align=left]Input[/align]
No more than 100 test cases. Each case contains only one integer N(N<=10^9).

[align=left]Output[/align]
For each N, print R(N) in one line.

[align=left]Sample Input[/align]

2
6
10
25
65

[align=left]Sample Output[/align]

4
0
8
12
16

Hint

For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)

题解:暴力枚举一下,要注意if(i>j)break;这一句,否则会重复计算WA掉。

#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
using namespace std;
//#define LOCAL

int main()
{
#ifdef LOCAL
freopen("in.txt", "r", stdin);
#endif // LOCAL
//Start
int n;
while(cin>>n)
{
int ans=0;
for(int i=0; i<sqrt(n); i++)
{
double j=sqrt(n-i*i);
if(i>j)break;
if((int)j==j)
{
if(i==0||j==0||i==j)ans+=4;
else ans+=8;
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: