您的位置:首页 > 其它

hdoj2509Be the Winner

2016-01-25 23:50 232 查看


Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2808    Accepted Submission(s): 1536


Problem Description

Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.

For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 

the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

 

Input

You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

 

Output

If a winning strategies can be found, print a single line with "Yes", otherwise print "No".

 

Sample Input

2
2 2
1
3

 

Sample Output

No
Yes

 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
using namespace std;
int main()
{
int i,j,n,sum;
while(scanf("%d",&n)!=EOF){
int sum=0;bool sign=false;
for(i=0;i<n;++i){
scanf("%d",&j);
if(j>1)sign=true;
sum=sum^j;
}
if(sign){
if(sum==0)printf("No\n");
else printf("Yes\n");
}
else {
if(n&1)printf("No\n");
else printf("Yes\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdoj2509Be the Winne