您的位置:首页 > 其它

HDU 1175 连连看(DFS)

2016-01-25 21:38 417 查看
题目链接

Problem Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!

Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。

Sample Input

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0


Sample Output

YES
NO
NO
NO
NO
YES

题解:就是转折两次能不能从起点走到终点。所以用dire记录方向,ter记录转弯次数,DFS即可。
WA了好几次,原因是恢复起点的时候恢复成0了,恢复成原来的数值才行。还有就是第一次出发不算转折。
这代码耗时7878ms。


#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
using namespace std;
//#define LOCAL
int mp[1200][1200];
int n,m,flag,tar;
int sx,sy,ex,ey;
int dir[5][2]= {{0,0},{0,1},{1,0},{0,-1},{-1,0}};
void dfs(int x,int y,int dire,int ter)
{
if(x<=0||y<=0||x>n||y>m)return;
if(ter>2)return;
if(flag)return;
int nx,ny;
for(int i=1; i<=4; i++)
{
nx=x+dir[i][0];
ny=y+dir[i][1];
if(mp[nx][ny]==0)
{
mp[nx][ny]=-1;
if(dire==i)
{
dfs(nx,ny,i,ter);
mp[nx][ny]=0;
}
else
{
dfs(nx,ny,i,ter+1);
mp[nx][ny]=0;
}
}
if(nx==ex&&ny==ey)
{
if(dire==i)
{
if(ter<=2)flag=true;
return;
}
else
{
if(ter<2)flag=true;
return;
}
}
}
return;
}
int main()
{
#ifdef LOCAL
freopen("in.txt", "r", stdin);
#endif // LOCAL
//Start
ios::sync_with_stdio(false);
while(cin>>n>>m&&(n||m))
{
memset(mp,0,sizeof mp);
for(int i=1; i<=n; i++)
for(int j=1; j<=m; j++)
cin>>mp[i][j];
int N;
cin>>N;
while(N--)
{
flag=false;
cin>>sx>>sy>>ex>>ey;
if(mp[sx][sy]==0||mp[ex][ey]==0)
printf("NO\n");
else if(mp[sx][sy]!=mp[ex][ey])
printf("NO\n");
else
{
tar=mp[sx][sy];
mp[sx][sy]=-1;
dfs(sx,sy,0,-1);
mp[sx][sy]=tar;
if(flag)printf("YES\n");
else printf("NO\n");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: