您的位置:首页 > 其它

poj 1065 Wooden Sticks【贪心】

2016-01-25 21:01 483 查看
Wooden Sticks

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 20341Accepted: 8582
Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be
2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case,
and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output

The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output
2
1
3

题意:
题目给出了每个木棍的长度和重量,要求的是最少有几个递增子序列。
思路:
先按照木棍长度排序,再对木棍重量更新;
AC代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct node{
int l,w;
};
node p[5050];
bool vis[5050];
bool operator < (const node a, const node b)
{
if(a.l == b.l)
return a.w < b.w;
return a.l < b.l;
}
int main(){
int T;
scanf("%d", &T);
while(T--){
memset(vis, 0, sizeof(vis));
int n;
scanf("%d", &n);
int i,j;
int num = 0;
int a;
for(i = 0; i < n; i++)
scanf("%d%d", &p[i].l, &p[i].w );
sort(p, p+n);
for(i = 0; i < n; i++)
{
a = p[i].w;
if(!vis[i])
{
for(j = i+1; j < n; j++)
{
if(a <= p[j].w && !vis[j])
{
vis[j] = 1;
a = p[j].w;
}
}
num++;
}
}
printf("%d\n", num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: