您的位置:首页 > 其它

HDU 5591 ZYB's Game(博弈水题)

2016-01-25 11:09 274 查看
ZYB’s Game

Time Limit: 1000msMemory Limit: 65536KB 64-bit integer IO format: %I64d Java class name: Main

Submit Status

ZYB played a game named NumberBomb with his classmates in hiking:a host keeps a number in [1,N] in mind,then

players guess a number in turns,the player who exactly guesses X loses,or the host will tell all the players that

the number now is bigger or smaller than X.After that,the range players can guess will decrease.The range is [1,N] at first,each player should guess in the legal range.

Now if only two players are play the game,and both of two players know the X,if two persons all use the best strategy,and the first player guesses first.You are asked to find the number of X that the second player

will win when X is in [1,N].

Input

In the first line there is the number of testcases T.

For each teatcase:

the first line there is one number N.

1≤T≤100000,1≤N≤10000000

Output

For each testcase,print the ans.

Sample Input

1

3

Sample Output

1

#include <bits/stdc++.h>
using namespace std;

int main()
{
int t;
scanf("%d",&t);
for(int i=1;i<=t;i++)
{
int x;
scanf("%d",&x);
printf("%d\n",x&1);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: