您的位置:首页 > 其它

POJ【2236】Wireless Network

2016-01-25 09:37 295 查看
Wireless Network

Time Limit: 10000MSMemory Limit: 65536K
Total Submissions: 20631Accepted: 8679
Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken.
The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded
as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In
the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of
following two formats:

1. "O p" (1 <= p <= N), which means repairing computer p.

2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output
FAIL
SUCCESS

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
using namespace std;
const int maxn = 1010;
int fa[maxn],d,N;
struct Node
{
int x,y;
}node[maxn];                                //保存每个结点的坐标
bool dist(Node &node1,Node &node2)          //判断2个结点之间的距离是否小于d
{
return ((node1.x-node2.x)*(node1.x-node2.x)+(node1.y-node2.y)*(node1.y-node2.y)) <= d*d;
}
int Find(int x)
{
if(fa[x] == -1 || fa[x] == x) return x; //多加了一个条件当fa[x]==-1时的判断
else if(x != fa[x])
fa[x] = Find(fa[x]);
return fa[x];
}
int main()
{
char c;
scanf("%d%d",&N,&d);
memset(fa,-1,sizeof(fa));
for(int i = 1 ; i <= N; i++)
scanf("%d%d",&node[i].x,&node[i].y);
while(scanf(" %c",&c) != EOF)            //换行符需要注意处理
{
if(c == 'O')
{
int x;
scanf("%d",&x);
fa[x] = x;
for(int i = 1 ; i <= N; i++)
if(i != x && fa[i] != -1 && dist(node[x],node[i]))
{
int fi = Find(i);
fa[fi] = x;              //合并
}
}
else
{
int a,b;
scanf("%d%d",&a,&b);
if(Find(a) == Find(b))           //2个点在同一个集合中
printf("SUCCESS\n");
else
printf("FAIL\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: