您的位置:首页 > 其它

ZOJ 1530 - Find The Multiple

2016-01-24 22:58 274 查看
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero (0) terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

[b]大致题意:[/b]

给个n,找n的十进制倍数,仅有 0 和 1 组成,找一个就行,随便哪一个。

[b]解题思路:[/b]

观察以下0,1串:

1

10 11

100 101 110 111

从n=1开始, 重复 n*10 与 n*10+1 ,由此遍历所有01串。

BFS,DFS皆可,以下采用DFS。

 #include <iostream>
#include <queue>
#include <cstdio>
using namespace std;
queue<unsigned long long> s;
int n;//输入
unsigned long long temp,p;
void bfs()
{
while(!s.empty())
s.pop();
temp=1;
s.push(temp);
while(!s.empty())
{
p=s.front();
s.pop();
if(p%n==0)
{
printf("%lld\n",p);//lld!
break;
}
s.push(p*10);
s.push(p*10+1);
}
}
int main(){
while(scanf("%d",&n),n)
{
bfs();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: