您的位置:首页 > 其它

ZOJ 1005 jugs

2016-01-24 18:42 435 查看
In the movie "Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle.

You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from one jug to the other. Pouring from one jug to the other stops when
the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A.

A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps are

fill A

fill B

empty A

empty B

pour A B

pour B A

success

where "pour A B" means "pour the contents of jug A into jug B", and "success" means that the goal has been accomplished.

You may assume that the input you are given does have a solution.

Input

Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal. You can assume 0 < Ca <=
Cb and N <= Cb <=1000 and that A and B are relatively prime to one another.

Output

Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line "success".
Output lines start in column 1 and there should be no empty lines nor any trailing spaces.

Sample Input

3 5 4
5 7 3

Sample Output

fill B
pour B A
empty A
pour B A
fill B
pour B A
success
fill A
pour A B
fill A
pour A B
empty B
pour A B
success
超时代码如下:(T^T 不懂为什么超时)
#include<iostream>

using namespace std;

int main()
{
int a, b, c, t;
while(cin >> a >> b >> c)
{
if (a == 1)
{
for(t = 1; t <= c; t++)
{
cout << "fill A" << endl;
cout << "pour A B" <<endl;
}
cout << "success" << endl;
}
t = 0;
while(t != c)
{
cout << "fill A" << endl;
cout << "pour A B" <<endl;
t += a;
if (t >= b)
{
t -= b;
cout << "empty B" <<endl;
cout << "pour A B" <<endl;
}
}
cout << "success" <<endl;
}
return 0;
}

通过代码如下(网上抄的):
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
int ca,cb,x;
int a,b,t;
while(cin>>ca>>cb>>x)
{
a=0,b=0;
while(1)
{
if(a==0)     //A装满
{
puts("fill A");
a=ca;
}
if(a==x||b==x) break;
puts("pour A B");
if(b+a>=cb)     //B装满了
a=b+a-cb,b=cb;
else
b=b+a,a=0;
if(a==x||b==x) break;
if(b==cb)
{
puts("empty B");
b=0;
}
}
puts("success");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: