您的位置:首页 > 其它

Hdu1241Oil Deposits

2016-01-24 13:32 288 查看




Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20759    Accepted Submission(s): 11925


[align=left]Problem Description[/align]
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

[align=left]Input[/align]
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

[align=left]Output[/align]
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

[align=left]Sample Input[/align]

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

[align=left]Sample Output[/align]

0
1
2
2

 
最经典的DFS题,非常适合像我这种新手。
//////////////////////////////////////////////////////////////////
主要思路是
主循环里遍历寻找未走过的@,从此处开始dfs;
dfs里面通过循环完成深度搜索,将所有与之有关联的都标记下,完成这个deposit的深搜后sum+1;
然后继续遍历搜索;
一次AC.
//////////////////////////////////////////////////////////////////
#include<cstdio>

#include<iostream>

#include<cstring>

using namespace std;

int m,n;

char map[100][100];

int zhi[100][100];

int dm[8]={-1,1,0,0,-1,-1,1,1};

int dn[8]={0,0,-1,1,-1,1,-1,1};

char ch;
int dfs(int a,int b)

{

    map[a][b]=1;

    int c,d;

    for(int i=0;i<8;i++)

    {

        c=a+dm[i];

        d=b+dn[i];

        if(c>=0&&c<m&&d>=0&&d<n)

            if(map[c][d]=='@')

                if(!zhi[c][d])

                {

                    dfs(c,d);

                }
    }

    return 0;

}
int main()

{

    while(scanf("%d%d",&m,&n)!=EOF&&

          m&&n)

    {

        int sum=0;

        memset(zhi,0,sizeof(zhi));

        for(int i=0;i<m;i++)

        {

            for(int j=0;j<n;j++)

            {

                cin >> map[i][j];

            }

        }

        for(int i=0;i<m;i++)

            for(int j=0;j<n;j++)

                if(map[i][j]=='@'&&(!zhi[i][j]))

                    {

                        sum++;

                        dfs(i,j);

                    }

        printf("%d\n",sum);

    }

    return 0;

}
//////////////////////////////////////////////////////
下面这个只是标记的位置改了下,本质上没有区别
#include<cstdio>

#include<iostream>

#include<cstring>

using namespace std;

int m,n;

char map[100][100];

int zhi[100][100];

int dm[8]={-1,1,0,0,-1,-1,1,1};

int dn[8]={0,0,-1,1,-1,1,-1,1};

char ch;
int dfs(int a,int b)

{

    int c,d;

    for(int i=0;i<8;i++)

    {

        c=a+dm[i];

        d=b+dn[i];

        if(c>=0&&c<m&&d>=0&&d<n)

            if(map[c][d]=='@')

                if(!zhi[c][d])

                {

                    map[c][d]=1;

                    dfs(c,d);

                }
    }

    return 0;

}
int main()

{

    while(scanf("%d%d",&m,&n)!=EOF&&

          m&&n)

    {

        int sum=0;

        memset(zhi,0,sizeof(zhi));

        for(int i=0;i<m;i++)

        {

            for(int j=0;j<n;j++)

            {

                cin >> map[i][j];

            }

        }

        for(int i=0;i<m;i++)

            for(int j=0;j<n;j++)

                if(map[i][j]=='@'&&(!zhi[i][j]))

                    {

                        map[i][j]=1;

                        sum++;

                        dfs(i,j);

                    }

        printf("%d\n",sum);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: