您的位置:首页 > 其它

hdu 5616

2016-01-23 23:24 316 查看

Baby Ming and Weight lifting

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 178 Accepted Submission(s): 77


[align=left]Problem Description[/align]
Baby Ming is fond of weight lifting. He has a barbell pole(the weight of which can be ignored) and two different kinds of barbell disks(the weight of which are respectively a

and b

), the amount of each one being infinite.

Baby Ming prepare to use this two kinds of barbell disks to make up a new one weighted C

(the barbell must be balanced), he want to know how to do it.



[align=left]Input[/align]
In the first line contains a single positive integer T

, indicating number of test case.

For each test case:

There are three positive integer a,b

, and C

.

1≤T≤1000,0<a,b,C≤1000,a≠b

[align=left]Output[/align]
For each test case, if the barbell weighted C

can’t be made up, print Impossible.

Otherwise, print two numbers to indicating the numbers of a

and b

barbell disks are needed. (If there are more than one answer, print the answer with minimum a+b

)

[align=left]Sample Input[/align]

2

1 2 6
1 4 5

[align=left]Sample Output[/align]

2 2
Impossible

[align=left]Source[/align]
BestCoder Round #69 (div.2)

题意 :t组数据 每组a b c
两种杠盘 a,b
目标质量 c

杠铃是成双出现的,然后只要枚举就可以了 注意优化

#include<iostream>
#include<cstdio>
#define LL __int64
using namespace std;
int t;
int a,b,c;
int flag;
int tt,ansa,ansb;
int main()
{
while(scanf("%d",&tt)!=EOF)
{
for(int i=1; i<=tt; i++)
{
flag=0;
scanf("%d%d%d",&a,&b,&c);
if(c%2)
printf("Impossible\n");
else
{
if(a<b)
{
t=a;
a=b;
b=t;
flag=1;
}
int gg=0;
for(int j=0; j<=c/2/a; j++)
for(int k=0; k<=c/2/b; k++)
{
if(j*a+k*b==c/2)
{
ansa=j;
ansb=k;
gg=1;
break;
}
}
if(gg==0)
printf("Impossible\n");
else
{
if(flag)
printf("%d %d\n",2*ansb,2*ansa);
else
printf("%d %d\n",2*ansa,2*ansb);
}

}

}
}

return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: