您的位置:首页 > 其它

HDU1520 Anniversary party(树形DP)

2016-01-23 13:32 330 查看
Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V.
E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating)
attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number
in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:

L K

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line

0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0


Sample Output

5


我用vector实现链表建树

状态转移方程:

dp[i][0]表示第i个人参加,dp[i][1]表示第i个人没有参加

dp[u][0]+=max(dp[v][0],dp[v][1]); 上司不参加,下属可以参加也可以不参加

dp[u][1]+=dp[v][0]; 上司参加,下属一定不参加

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>G[6005];
int f[6005];
int dp[6005][2];
void dfs(int cur)
{
for(int i=0;i<G[cur].size();i++)
{
dfs(G[cur][i]);
dp[cur][1]+=dp[G[cur][i]][0];
dp[cur][0]+=max(dp[G[cur][i]][1],dp[G[cur][i]][0]);
}
}
int main(void)
{
int n,u,v;
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
{
G[i].clear();
f[i]=-1;
scanf("%d",&dp[i][1]);
dp[i][0]=0;
}
while(scanf("%d%d",&u,&v)&&u&&v)
{
f[u]=v;
G[v].push_back(u);
}
int a=1;
while(f[a]!=-1)
a=f[a];
dfs(a);
printf("%d\n",max(dp[a][0],dp[a][1]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: