您的位置:首页 > 其它

Crashing Robots(POJ_2632)

2016-01-22 10:34 387 查看

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots
occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the
robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.

A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in
the NS-direction.

The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.

Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.



Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order.

An instruction has the following format:

< robot #> < action> < repeat>

Where is one of
L: turn left 90 degrees,

R: turn right 90 degrees, or

F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case:
Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)

Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.

OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

Source
Nordic 2005

代码                                                                                                                          



一道简单的模拟题,但是WA了好多次= =debug de的恶心= =目测是自己方法太挫才会有各种问题=QAQ

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
int k, a, b, n, m;
int g[110][110];
int x[110], y[110], d[110];
char s[5];
scanf("%d", &k);
while(k--)
{
memset(g, 0, sizeof(g));
scanf("%d %d %d %d", &a, &b, &n, &m);
for(int i = 1; i <= n; i++)
{
scanf("%d %d %s", &x[i], &y[i], s);
if(strcmp(s, "N") == 0)
d[i] = 1;
else if(strcmp(s, "E") == 0)
d[i] = 2;
else if(strcmp(s, "S") == 0)
d[i] = 3;
else
d[i] = 0;
g[x[i]][y[i]] = i;
}
int flag = 0, crash1, crash2;
int num, cnt;
while(m--)
{
scanf("%d %s %d", &num, s, &cnt);
if(!flag)
{
if(strcmp(s, "L") == 0)
{
d[num] = (d[num] + 4 - cnt % 4) % 4;
}
else if(strcmp(s, "R") == 0)
{
d[num] = (d[num] + cnt) % 4;
}
else
{
if(d[num] == 0)
{
for(int i = x[num] - 1; i >= (0 < x[num]-cnt ? x[num]-cnt : 1); i--)
{
if(g[i][y[num]])
{
crash1 = num;
crash2 = g[i][y[num]];
flag = 2;
break;
}
}
if(!flag)
{
if(x[num] - cnt <= 0)
{
crash1 = num;
flag = 1;
}
else
{
g[x[num]][y[num]] = 0;
g[x[num]-cnt][y[num]] = num;
x[num] -= cnt;
}
}
}
else if(d[num] == 1)
{
for(int i = y[num] + 1; i <= (b > y[num]+cnt ? y[num]+cnt : b); i++)
{
if(g[x[num]][i])
{
crash1 = num;
crash2 = g[x[num]][i];
flag = 2;
break;
}
}
if(!flag)
{
if(y[num] + cnt > b)
{
crash1 = num;
flag = 1;
}
else
{
g[x[num]][y[num]] = 0;
g[x[num]][y[num]+cnt] = num;
y[num] += cnt;
}
}
}
else if(d[num] == 2)
{
for(int i = x[num] + 1; i <= (a > x[num]+cnt ? x[num]+cnt : a); i++)
{
if(g[i][y[num]])
{
crash1 = num;
crash2 = g[i][y[num]];
flag = 2;
break;
}
}
if(!flag)
{
if(x[num] + cnt > a)
{
crash1 = num;
flag = 1;
}
else
{
g[x[num]][y[num]] = 0;
g[x[num]+cnt][y[num]] = num;
x[num] += cnt;
}
}
}
else
{
for(int i = y[num] - 1; i >= (0 < y[num]-cnt ? y[num]-cnt : 1); i--)
{
if(g[x[num]][i])
{
crash1 = num;
crash2 = g[x[num]][i];
flag = 2;
break;
}
}
if(!flag)
{
if(y[num] - cnt <= 0)
{
crash1 = num;
flag = 1;
}
else
{
g[x[num]][y[num]] = 0;
g[x[num]][y[num]-cnt] = num;
y[num] -= cnt;
}
}
}
}
}
}
if(!flag)
printf("OK\n");
else if(flag == 1)
{
printf("Robot %d crashes into the wall\n", crash1);
}
else
{
printf("Robot %d crashes into robot %d\n", crash1, crash2);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: