您的位置:首页 > 产品设计 > UI/UE

1041. Be Unique (20)

2016-01-21 11:29 381 查看
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there
are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:
7 5 31 5 88 67 88 17

Sample Output 1:
31

Sample Input 2:
5 888 666 666 888 888

Sample Output 2:
None


#include <iostream>
#include <cstdio>
#include <vector>

using namespace std;

#define MAX_NUM 10001

int hist[MAX_NUM];

int main(){
int n;
scanf("%d", &n);

fill_n(hist, MAX_NUM, 0);
vector<int> input;

for(int i = 0; i < n; ++i){
int num;
scanf("%d", &num);
hist[num]++;
input.push_back(num);
}

for(int i = 0; i < n; ++i){
if(hist[input[i]] == 1){
cout << input[i];
return 0;
}
}

cout << "None";

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ PAT 1041. Be Unique