您的位置:首页 > 其它

【南理oj】5 - Binary String Matching(水)

2016-01-20 18:27 288 查看


Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3

描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the
pattern A appeared at the posit

输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer
than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011


样例输出
3
0
3


来源
网络
上传者
naonao 

 

挺简单的。

代码如下:

#include <cstdio>
#include <cstring>
char base[14];
char pr[1111];
int l1,l2;
bool check(int n)
{
for (int i=0;i<l1;i++)
{
if (base[i]!=pr[n++])
return false;
}
return true;
}
int main()
{
int u;
int l;
int ans;
scanf ("%d",&u);
while (u--)
{
scanf ("%s",base);
scanf ("%s",pr);
l1=strlen(base);
l2=strlen(pr);
l=l2-l1;
ans=0;
for (int i=0;i<=l;i++)
{
if (check(i))
ans++;
}
printf ("%d\n",ans);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: