您的位置:首页 > 其它

Red and Black HDU 1312

2016-01-20 08:58 260 查看
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 

Sample Output

45
59
6
13

 

#include<stdio.h>
char a[30][30];
int n,m,z;
int b[4][2]= {{1,0},{0,1},{-1,0},{0,-1}};
void dfs(int i,int j)
{
z++;
a[i][j]='#';
for(int w=0; w<4; w++)
{
int x=i+b[w][0];
int y=j+b[w][1];

if(x<n&&y<m&&x>=0&&y>=0&&a[x][y]=='.')
dfs(x,y);
}
return ;
}
int main()
{
while(scanf("%d%d*c",&m,&n)!=EOF)
{
if(m==0&&n==0)
break;
int i,j,pi,qi;
for(i=0; i<n; i++)
scanf("%s",a[i]);
getchar();
for(i=0; i<n; i++)
{
for(j=0; j<m; j++)
{
//scanf("%c",&a[i][j]);
if(a[i][j]=='@')
{
pi=i;
qi=j;
break;
}
}
//getchar ();
}
z=0;
dfs(pi,qi);
printf("%d\n",z);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: