您的位置:首页 > 其它

hdu 1034 Candy Sharing Game

2016-01-19 22:16 316 查看
[align=left]Problem Description[/align]
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to
the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

[align=left]Input[/align]
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count
of 0. Each input number is on a line by itself.

[align=left]Output[/align]
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

[align=left]Sample Input[/align]

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0


[align=left]Sample Output[/align]

15 14
17 22
4 8

Hint
The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
这题是模拟,只要读清题意,直接按步骤进行即可[code]#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int N,a[100000];
while(scanf("%d",&N)&&N!=0)
{
int num=0,j;
for(int i=0;i<N;++i)
{
scanf("%d",&a[i]);
}
while(1)
{
//判断是否结束
for(j=1;j<N;++j)
{
if(a[j-1]!=a[j]) break;
}
if(j==N) break;
++num;
//进行模拟
int temp=a[N-1]/2;
for(int i=N-1;i>0;--i)
{
a[i]=a[i]/2;
a[i]+=a[i-1]/2;
}
a[0]=a[0]/2;
a[0]+=temp;
for(int i=0;i<N;++i)
{
if(a[i]%2==1) ++a[i];
}
}
printf("%d %d\n",num,a[0]);
}
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: