您的位置:首页 > 其它

POJ 2243 - Knight Moves

2016-01-19 13:49 417 查看
B - Knight Moves
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
2243

Appoint description:
System Crawler (2016-01-04)System Crawler (2016-01-13)

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of
the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6


Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.


双向BFS练手

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

#define N 10

struct node{
int x,y;
node(int xx,int yy):x(xx),y(yy){}
};

char a,c;
int b,d;
int vis

;
int vx[]={1,1,2,2,-1,-1,-2,-2};
int vy[]={2,-2,1,-1,2,-2,1,-1};
int color

;
int fx,fy,ex,ey;

int bfs(){
if (fx==ex && fy==ey)
return 0;

queue<node> p,q;
memset(vis,0,sizeof(vis));
memset(color,0,sizeof(color));
vis[fx][fy]=0;
vis[ex][ey]=1;
color[fx][fy]=1;
color[ex][ey]=2;

p.push(node(fx,fy));
q.push(node(ex,ey));

while (!p.empty() || !q.empty()){
if (!p.empty()){
node cur=p.front();
p.pop();

int x=cur.x,y=cur.y;
// cout<<1<<' '<<x<<' '<<y<<endl;
for (int i=0;i<8;i++){
int tx=x+vx[i];
int ty=y+vy[i];
if (tx<0 || tx>7 || ty<0 || ty>7)
continue;
if (color[tx][ty]==0){
color[tx][ty]=1;
vis[tx][ty]=vis[x][y]+1;
//cout<<1<<' '<<tx<<' '<<ty<<endl;
p.push(node(tx,ty));
}else if (color[tx][ty]==2){
return vis[x][y]+vis[tx][ty];
}
}
}

if (!q.empty()){
node cur=q.front();
q.pop();

int x=cur.x,y=cur.y;
//  cout<<2<<' '<<x<<' '<<y<<endl;
for (int i=0;i<8;i++){
int tx=x+vx[i];
int ty=y+vy[i];
if (tx<0 || tx>7 || ty<0 || ty>7)
continue;
if (color[tx][ty]==0){
color[tx][ty]=2;
vis[tx][ty]=vis[x][y]+1;
//cout<<2<<' '<<tx<<' '<<ty<<endl;
q.push(node(tx,ty));
}else if (color[tx][ty]==1){
return vis[x][y]+vis[tx][ty];
}
}
}
}

return -1;
}

int main(){
while (scanf("%c%d %c%d",&a,&b,&c,&d)!=EOF){
getchar();
fx=a-'a';
fy=b-1;
ex=c-'a';
ey=d-1;
//cout<<fx<<fy<<' '<<ex<<ey<<endl;
int ans=bfs();
printf("To get from %c%d to %c%d takes %d knight moves.\n",a,b,c,d,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: