您的位置:首页 > 其它

FatMouse's Speed--hdu1160(dp+输出路径)

2016-01-19 11:33 405 查看
[align=left]Problem Description[/align]
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

[align=left]Input[/align]
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

[align=left]Output[/align]
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m
then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m
]

and

S[m[1]] > S[m[2]] > ... > S[m
]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

[align=left]Sample Input[/align]

6008 1300

6000 2100

500 2000

1000 4000

1100 3000

6000 2000

8000 1400

6000 1200

2000 1900

[align=left]Sample Output[/align]

4
4
5
9
7

题目大意:
这是个大英文题啊

他给你老鼠的体重和奔跑的速度

然后当体重呈升序的时候 速度的最长下降序列

这都不重要 重要的是还要打印路径

分析:

就是先对体重排序

然后求最长下降序列

再求的过程中记录路径 最后输出

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<stdlib.h>

using namespace std;

#define INF 0xfffffff
#define N 5000

struct node
{
int num,w,s;
}a
;

int cmp(const void *x,const void *y)
{
struct node *c,*d;
c=(struct node *)x;
d=(struct node *)y;
if(c->w!=d->w)
return c->w-d->w;
else
return d->s-c->s;
}
int main()
{
int i=0,pre
,dp
;
while(scanf("%d %d",&a[i].w,&a[i].s)!=EOF)
{
dp[i]=1;
pre[i]=0;
a[i].num=i+1;
i++;
}
int n=i,b,Max=0;
qsort(a,n,sizeof(a[0]),cmp);
for(i=0;i<n;i++)
{
for(int j=0;j<i;j++)
{
if(a[j].w<a[i].w&&a[j].s>a[i].s&&dp[j]+1>dp[i])
{
dp[i]=dp[j]+1;
pre[i]=j;
if(Max<dp[i])
{
b=i;
Max=dp[i];
}
}
}
}
int aa
;
printf("%d\n",Max);
aa[0]=a[b].num;
i=1;
while(1)
{
int j=pre[b];
if(j==0)
break;
aa[i++]=a[j].num;
b=j;
}
for(int j=i-1;j>=0;j--)
printf("%d\n",aa[j]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: