您的位置:首页 > 运维架构

POJ 3614 Pseudoprime numbers(快速幂)

2016-01-18 16:07 477 查看
[align=center]Pseudoprime numbers[/align]

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 8035
Accepted: 3341
Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p).
That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p,
known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output
no
no
yes
no
yes
yes


题意:专业名词太多,没看懂。 p不是素数,且a^p对p取模等于a,输出yes,其他的输出no。

题解:判断p是否是素数那部分直接蛮力求就好,打表打不下。很简单啦。

代码如下:

#include<cstdio>
#include<cstring>
#define ll long long

bool is_prime(ll n)
{
ll i;
for(i=2;i*i<n;++i)
{
if(n%i==0)
return false;
}
return true;
}

ll result(ll n,ll m)
{
ll ans=1,cnt=m;
while(cnt)
{
if(cnt&1)
ans=(ans*n)%m;
cnt>>=1;
n=(n*n)%m;
}
return ans;
}

int main()
{
ll p,a;
while(scanf("%lld%lld",&p,&a)&&p||a)
{
if(is_prime(p))
printf("no\n");
else if(a==result(a,p))
printf("yes\n");
else if(a!=result(a,p))
printf("no\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: