您的位置:首页 > 编程语言 > Go语言

UVA 543 Goldbach's Conjecture

2016-01-18 13:58 489 查看

Goldbach's Conjecture

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 47 Accepted Submission(s) : 15
[align=left]Problem Description[/align]
In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be

written as the sum of two odd prime numbers.

For example:

8 = 3 + 5. Both 3 and 5 are odd prime numbers.

20 = 3 + 17 = 7 + 13.

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

[align=left]Input[/align]
The input will contain one or more test cases.

Each test case consists of one even integer n with 6 <= n < 1000000.

Input will be terminated by a value of 0 for n.

[align=left]Output[/align]
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding
up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

[align=left]Sample Input[/align]

8
20
42
0


[align=left]Sample Output[/align]

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37


#include<stdio.h>
#include<math.h>
int isprime(int n)
{
int i;
for(i=2;i<=sqrt(n);i++)
{
if(n%i==0) return 0;
}
return 1;
}
int main (void)
{
int n;
while(scanf("%d",&n)!=EOF&&n!=0)
{
int count=0;
for(int i=2; i<500000;i++)
{
if(isprime(i)&&isprime(n-i))
{
printf("%d = %d + %d\n",n,i,n-i);
count=1;
break;
}
}
if(count==0)
{
printf("Goldbach's conjecture is wrong.\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: