您的位置:首页 > 其它

HDOJ 2710 Max Factor (筛素法求最大因子)

2016-01-17 21:59 357 查看


Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5557    Accepted Submission(s): 1799


Problem Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular,
a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

 

Input

* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line

 

Output

* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

 

Sample Input

4
36
38
40
42

 

Sample Output

38

题意:给你n个数,求素因子最大的那个数,如果素因子大小相同,结果为最小的那个数

思路:在素数筛选过程中,用一个数组存储每个数的最大因子,因为因子为素数,所以说最后一个乘积所用的i是乘积数最大因子,然后过程比较就行了

ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define INF 0xfffffff
using namespace std;
int v[1000100];
int ans[1000100];
void db()
{
memset(v,0,sizeof(v));
v[1]=1;
for(int i=2;i<1000100;i++)
{
if(!v[i])
{
ans[i]=i;
for(int j=i*2;j<1000100;j+=i)
ans[j]=i,v[j]=1;
}
}
}
int main()
{
db();
int n,a,i;
while(scanf("%d",&n)!=EOF)
{
int M=-INF;
int Ans=-INF;
for(i=0;i<n;i++)
{
scanf("%d",&a);
if(ans[a]>M)
{
M=ans[a];
Ans=a;
}
else if(ans[a]==M)
{
if(a>Ans)
Ans=a;
}
}
printf("%d\n",Ans);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: