您的位置:首页 > 其它

Red and Black(poj 1979 bfs)

2016-01-17 10:04 393 查看
Red and Black

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 27891Accepted: 15142
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
char map[25][25];
bool vis[25][25];
int dx[4]={0,0,1,-1},dy[4]={1,-1,0,0};
int w,h;
int sx,sy;
struct node
{
int x,y;
};
int bfs()
{
queue<node> q;
int ans=0;
memset(vis,0,sizeof(vis));
node s,temp;
s.x=sx,s.y=sy;
q.push(s);
while(!q.empty())
{
s=q.front();
q.pop();
ans++;
for(int i=0;i<4;i++)
{
temp.x=s.x+dx[i];
temp.y=s.y+dy[i];
if(temp.x>=0&&temp.x<h&&temp.y>=0&&temp.y<w&&vis[temp.x][temp.y]==0&&map[temp.x][temp.y]=='.')
{

vis[temp.x][temp.y]=1;
q.push(temp);

}
}
}
return ans;
}
int main()
{
int i,j;
freopen("in.txt","r",stdin);
while(scanf("%d%d",&w,&h))
{
if(w==0&&h==0)
break;
for(i=0;i<h;i++)
scanf("%s",map[i]);
for(i=0;i<h;i++)
for(j=0;j<w;j++)
if(map[i][j]=='@')
{
sx=i,sy=j;
break;
}

cout<<bfs()<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: