您的位置:首页 > 其它

POJ 3414 - Pots

2016-01-16 22:50 309 查看
H - Pots
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i) empty the pot i to the drain;
POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its
contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the
desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4


Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <string>
using namespace std;

#define N 105

struct node{
int x,y;
int opr,last;

node(){}
node(int xx,int yy,int oo,int ll){
x=xx;
y=yy;
opr=oo;
last=ll;
}
};

int vis

;
node p[N*N];
int l,r;
int a,b,c;

void add(){

}

void pr(int l){
int ans=0;
int op[N*N];
while (1){
op[ans++]=p[l].opr;
l=p[l].last;
if (p[l].opr==0)
break;
}

string st[]={"","FILL(1)","FILL(2)","DROP(1)","DROP(2)","POUR(1,2)","POUR(2,1)"};
printf("%d\n",ans);
for (int i=ans-1;i>=0;i--)
cout<<st[op[i]]<<endl;
}

void solve(){
l=0; r=1;
p[l]=node(0,0,0,0);
memset(vis,0,sizeof(vis));
vis[0][0]=true;

int x,y;
while (l<r){
//cout<<p[l].x<<' '<<p[l].y<<endl;
if (p[l].x==c || p[l].y==c){
pr(l);
return;
}

x=a;
y=p[l].y;
if (!vis[x][y]){
vis[x][y]=1;
p[r++]=node(x,y,1,l);
}

x=p[l].x;
y=b;
if (!vis[x][y]){
vis[x][y]=1;
p[r++]=node(x,y,2,l);
}

x=0;
y=p[l].y;
if (!vis[x][y]){
vis[x][y]=1;
p[r++]=node(x,y,3,l);
}

x=p[l].x;
y=0;
if (!vis[x][y]){
vis[x][y]=1;
p[r++]=node(x,y,4,l);
}

x=p[l].x-min(p[l].x,b-p[l].y);
y=p[l].y+min(p[l].x,b-p[l].y);
if (!vis[x][y]){
vis[x][y]=1;
p[r++]=node(x,y,5,l);
}

x=p[l].x+min(p[l].y,a-p[l].x);
y=p[l].y-min(p[l].y,a-p[l].x);
if (!vis[x][y]){
vis[x][y]=1;
p[r++]=node(x,y,6,l);
}

l++;
}

printf("impossible\n");
}

int main(){
while (scanf("%d%d%d",&a,&b,&c)!=EOF){
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: