您的位置:首页 > 大数据 > 人工智能

HDU 1789 Doing Homework again

2016-01-16 14:26 399 查看

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9936 Accepted Submission(s): 5803



[align=left]Problem Description[/align]
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce
his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

[align=left]Output[/align]
For each test case, you should output the smallest total reduced score, one line per test case.

[align=left]Sample Input[/align]

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4


[align=left]Sample Output[/align]

0
3
5


先对分数进行排序,如果分数一样,就按日期从小到大排,如果同一天有不同的分数,那么就往前找,被挤出来的就是要被加进去的罚分

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAXN=1010;

struct Node
{
int d,s;
}node[MAXN];

int vis[10000];

bool cmp(Node a,Node b)
{
if(a.s==b.s)
{
return a.d<b.d;
}
return a.s>b.s;
}

int main()
{
int T;
int n;
int j;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i=0;i<n;i++) scanf("%d",&node[i].d);
for(int i=0;i<n;i++) scanf("%d",&node[i].s);
sort(node,node+n,cmp);
memset(vis,0,sizeof(vis));
int ans=0;
for(int i=0;i<n;i++)
{
for(j=node[i].d;j>0;j--)        //排完序后,从截止日期往前找,找到没被占用的空间然后进行替代,最后被挤下来的就是最小的
{
if(!vis[j])
{
vis[j]=1;
break;
}
}
if(j==0)
ans+=node[i].s;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: