您的位置:首页 > 其它

Space Elevator(DP)

2016-01-15 21:05 337 查看
Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000).

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K

Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3

7 40 3

5 23 8

2 52 6

Sample Output

48

Hint

OUTPUT DETAILS:

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

一堆砖头,有c个,高度h,只能在海拔a以下使用,问最高能搭多高。

一看范围- -直接把物品拆开写背包,非常暴力的写法,但是数据水,过了- -,其实应该是用之前一个方法,dp[i][j]表示i个砖头到达j高度剩下最多第i种砖头的个数,这个只是加了递推的条件,懒得再写一遍了。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<utility>
#include<sstream>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
int dp[40005];
struct Node
{
int h,a,c;
}node[405];
bool cmp(Node a,Node b)
{
if(a.a == b.a)
return a .h < b.h;
return a.a < b.a;
}
int main()
{
#ifdef LOCAL
freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt","r",stdin);
//freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
#endif // LOCAL
int k;
scanf("%d",&k);
int he = 0;
for(int i = 1;i <= k;i++)
{
scanf("%d%d%d",&node[i].h,&node[i].a,&node[i].c);
he = max(he,node[i].a);
}
he = min(he,40000);
memset(dp,0,sizeof(dp));
sort(node + 1,node + 1 + k,cmp);
for(int i = 1;i <= k;i++)
{
dp[0] = 1;
for(int j = 1;j <= node[i].c;j++)
{
for(int kk = node[i].a;kk >= node[i].h;kk--)
dp[kk] = dp[kk] | dp[kk - node[i].h];
}
}
int ans = 0;
for(int j = ans;j <= he;j++)
if(dp[j])ans = max(ans,j);
printf("%d\n",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: